SNASharp v2019_05_05_0

Une nouvelle version de SNASharp est disponible
La page principale du projet est toujours la même

Cela se passe ici :  http://alloza.eu/david/WordPress3/?page_id=478

Voila le lien de téléchargement direct de la dernière version ( 2019_05_05_0):

Clic here to download the last version

Cette version intègre les évolutions récentes

  • Correction d’un bug lié au support du NWT300

Mis à part pour ceux qui possèdent un NWT300, il n’est pas nécessaire de mettre à jour vers cette version. Donc le NWT300 est pleinement supporté à partir de la version 2019_05_05_0.

Un grand merci à Patrick F6AZZ pour m’avoir prêté son NWT300, et me l’avoir laissé quelques jours le temps de corriger le bug. 

20Hz-300MHz F6AZZ NWT300 linearity test (after SNASharp calibration)
Note the high linearity of this analyzer
SSB filter test en « Both » mode ( use linear and logarithmic detectors).
NWT300 offer very low noise level and strong dynamic

Futures évolutions:

Les futures évolutions ne seront pas uniquement visuelles ou esthétiques. Le logiciel intégrera une première série d’extensions du protocole de communication vers les analyseurs. La compatibilité ascendante sera assurée, c’est à dire que les analyseur intégrant le protocole original de DL4JAL continuerons à être supportés. Ces nouvelles fonctions étant destinées à mieux gérer des analyseurs dotés de firmwares homemades.

Comme pour les  versions précédentes, pour pourvoir l’exécuter il faut:

1> avoir décompressé le zip ( il ne fonctionne pas directement lancé dans le fichier zip).

2> avoir le framework .NET 4.0 installé sur sa machine ( ou Mono si on est sur Mac ou PC Linux).

Pour l’utiliser sous Mac avec mono il faut lui demander d’utiliser la version 32 bits, car la version 64bits ne gère pas totalement les systèmes de fenêtre, donc  la ligne de commande ressemble à ça :


mono  — arch=32  SNASharp.exe

Pour ceux qui l’utilisent via Mono sous Ubuntu ne pas oublier que le niveau de privilège par défaut n’autorise pas les applications à accéder aux ports COM.

Vous pouvez intervenir directement via les commentaires en bas de l’article

Pour vous tenir informé des nouvelles versions
Le blog n’a pas actuellement de système d’abonnement aux articles.
Quand une nouvelle version est disponible, je l’annonce sur Twitter (entre autres) avec le tag #SNASharp

Il y a aussi un fil de discussion sur les forums de www.radioamateur.org, ici

Et je poste aussi un mail dans les listes de diffusion hyperfr et ATV

David.



Ce contenu a été publié dans SNA, SNASharp, Software. Vous pouvez le mettre en favoris avec ce permalien.

6 réponses à SNASharp v2019_05_05_0

  1. Roger dit :

    Bonsoir,
    Je viens de recevoir ma carte et je cherche a installer le firmware de José et ca coince au niveau du module ST-LINK/V2 .
    Mon PC fonctionne sous Windows 10 64bits .
    Le module ST-link n’est pas reconnu complètement .
    La mise a jour de son Firmware ( V2.J29.S7 ) a fonctionné mais il n’y a pas de dialogue entre le PC et le ST-Link quand je lance la commande Connect .
    Si vous avez une solution je suis preneur.
    Cordiale 73

    • David Alloza dit :

      Bonsoir Roger,
      Je suis un parfait débutant au niveau des outils pour STM32.
      Chez moi cela à correctement fonctionné en Windows10 64 bits.
      Je vais faire suivre à José pour voir si il a une suggestion.
      Cordialement,
      David, F4HTQ.

    • Jose Luu dit :

      Bonsoir Roger,
      Si tu as pu faire l’upgrade firmware, c’est que le PC cause bien au STLink. Lors du « connect » le soft st-link tente de communiquer avec le processeur.
      Dans le menu Target -> Settings, verifier:
      Connection setting: doit etre « SWD »
      Essayer diverses combinaisons de « Mode » et de « Reset Mode »
      Ici je connecte avec
      – Mode: normal
      – Reset Mode: software system reset

      73
      Jose

  2. Roger dit :

    Bonjour José ,
    Merci pour les infos , je vais faire les manips que vous indiquez .
    73
    Roger

  3. Roger dit :

    Bonsoir,
    J’ai essayé plusieurs combinaison sans résultat .
    J’obtiens un message d’erreur de connexion USB avec le ST-link alors que la mise a jour du Firmware fonctionne parfaitement.
    73
    Roger

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *